synopsys arc architecture · Supported
Maintainers
- M Vineet Gupta <vgupta@kernel.org>
Paths
- F
Documentation/arch/arc - F
Documentation/devicetree/bindings/arc/* - F
Documentation/devicetree/bindings/interrupt-controller/snps,arc* - F
arch/arc/ - F
drivers/clocksource/arc_timer.c - F
drivers/tty/serial/arc_uart.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-doc (capped at 30), ordered by date desc.
-
STALE142d
[PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE142d
REVIEWED: 1 (1M) [PATCH v3 02/29] arc: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE160d
[PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE160d
[PATCH v2 02/28] arc: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE209d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE209d
[PATCH 02/28] arc: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE293d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE293d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE293d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE293d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE293d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE461d
Re: [PATCH v12 06/28] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
2025-04-24 · "Arnd Bergmann" <arnd@arndb.de> -
STALE1094d
[PATCH v9 01/42] mm: Rename arch pte_mkwrite()'s to pte_mkwrite_novma()
2023-06-13 · Rick Edgecombe <rick.p.edgecombe@intel.com> -
STALE1111d
LANDED: 1 (0M) [PATCH v2 27/27] locking/atomic: treewide: delete arch_atomic_*() kerneldoc
2023-06-05 · Mark Rutland <mark.rutland@arm.com> -
STALE1111d
LANDED: 1 (0M) [PATCH v2 05/27] locking/atomic: arc: add preprocessor symbols
2023-06-05 · Mark Rutland <mark.rutland@arm.com> -
STALE1111d
LANDED: 1 (0M) [PATCH v2 04/27] locking/atomic: make atomic*_{cmp,}xchg optional
2023-06-05 · Mark Rutland <mark.rutland@arm.com> -
STALE1155d
[PATCH 26/26] locking/atomic: treewide: delete arch_atomic_*() kerneldoc
2023-05-22 · Mark Rutland <mark.rutland@arm.com> -
STALE1155d
[PATCH 05/26] locking/atomic: arc: add preprocessor symbols
2023-05-22 · Mark Rutland <mark.rutland@arm.com> -
STALE1155d
[PATCH 04/26] locking/atomic: make atomic*_{cmp,}xchg optional
2023-05-22 · Mark Rutland <mark.rutland@arm.com> -
STALE1228d
REVIEWED: 17 (13M) [PATCH v8 13/40] mm: Make pte_mkwrite() take a VMA
2023-03-19 · Rick Edgecombe <rick.p.edgecombe@intel.com> -
STALE1171d
REVIEWED: 1 (0M) [PATCH v5 15/26] arc: Remove empty <uapi/asm/setup.h>
2023-03-06 · Alexandre Ghiti <hidden> -
STALE1246d
REVIEWED: 1 (0M) [PATCH v4 14/24] arc: Remove empty <uapi/asm/setup.h>
2023-03-02 · Alexandre Ghiti <hidden> -
STALE1228d
REVIEWED: 17 (13M) [PATCH v7 13/41] mm: Make pte_mkwrite() take a VMA
2023-02-27 · Rick Edgecombe <rick.p.edgecombe@intel.com> -
STALE1247d
REVIEWED: 1 (0M) [PATCH v6 13/41] mm: Make pte_mkwrite() take a VMA
2023-02-18 · Rick Edgecombe <rick.p.edgecombe@intel.com> -
STALE1242d
[PATCH v3 14/24] arc: Remove empty <uapi/asm/setup.h>
2023-02-14 · Alexandre Ghiti <hidden> -
STALE1749d
[PATCH 2/2] kbuild: use more subdir- for visiting subdirectories while cleaning
2021-10-13 · Masahiro Yamada <masahiroy@kernel.org> -
STALE1874d
REVIEWED: 1 (0M) [PATCH v3 3/9] arc: remove support for DISCONTIGMEM
2021-06-08 · Mike Rapoport <rppt@kernel.org> -
STALE1874d
REVIEWED: 1 (0M) [PATCH v3 2/9] arc: update comment about HIGHMEM implementation
2021-06-08 · Mike Rapoport <rppt@kernel.org> -
STALE1877d
[PATCH v2 3/9] arc: remove support for DISCONTIGMEM
2021-06-04 · Mike Rapoport <rppt@kernel.org> -
STALE1877d
[PATCH v2 2/9] arc: update comment about HIGHMEM implementation
2021-06-04 · Mike Rapoport <rppt@kernel.org>